Degraded UI and issue event processing performance

Incident Report for The Plugin People

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 17:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 03, 2025 - 16:12 UTC

Monitoring

We identified the problem (a hot DB query path), and a fix is being prepared for deployment.
Posted Dec 03, 2025 - 16:10 UTC

Investigating

We are currently investigating this issue.
Posted Dec 03, 2025 - 14:20 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Outbound notification processing, User Interface).