(US region) Delayed event processing impacting outbound notifications

Incident Report for The Plugin People

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 02:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 02:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 01:27 UTC

Update

We're deploying a 'speedup' in the US region that will help with the current bottleneck.
Posted Dec 03, 2025 - 22:54 UTC

Identified

A large influx of events is hitting our US based servers causing a backlog of processing in that region resulting in delays to outbound mail. There is no data loss, we will catch up. There are some improvements in the works to help in this scenario but they won't be ready until tomorrow.
Posted Dec 03, 2025 - 22:33 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Outbound notification processing).