AWS outage affecting JEMHC

Incident Report for The Plugin People

Resolved

closing out, DR not required, no data loss occurred.
Posted Oct 20, 2025 - 13:18 UTC

Monitoring

JEMHC is now available, we continue to monitor.
Posted Oct 20, 2025 - 11:52 UTC

Update

We are currently waiting for AWS to 'start' service nodes, that is currently a throttled action. See https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:49 UTC

Identified

AWS (US, Virginia) region has/is experiencing problems from 0800 UTC today.

Inbound mail is still being processed but outbound notifications and the User Interface are not available.

We were not able to access statuspage to log this here until recently, see https://thepluginpeople.atlassian.net/wiki/spaces/JEMHC/blog/2025/10/20/5424152578/Major+app+outage+for+US+region for prior notice.

We hear that service restoration is underway and are actively monitoring.

DR process is already underway but we have not flipped over yet (there is some data loss impact from a full DR swap), as the situation may clear in the near future.
Posted Oct 20, 2025 - 10:29 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Data Pack purchasing, Outbound notification processing, Licensing, User Interface).