The root cause of the impact on the job execution framework has been tracked to one specific host with one specific kind of problem related to o365. We are now ramping up job processing volumes for high volume customers that have a backlog of events.
We will be implementing changes to better handle the specific problem here to prevent it from recurring.
Posted Apr 23, 2025 - 11:08 UTC
Update
The root cause has been identified as a problem with the job scheduler framework responsible for webhook processing and outbound mail, as well as inbound mail retrieval/processing. There is no data loss.
At this time we are collecting all Jira "work item" updates, just not able to process them in real-time. Inbound mail is also backed up. We are taking steps to mitigate the problem.
More when we have it, team is actively working on this, sorry for delays ...
Posted Apr 22, 2025 - 20:11 UTC
Update
Problem is localized to app users with Jira installations with data residency regions set outside of EU
Posted Apr 22, 2025 - 17:10 UTC
Identified
We are continuing to isolate and resolve this issue. Apologies for the inconvenience caused by this outage.
Posted Apr 22, 2025 - 16:47 UTC
Update
We are seeing large delays in inbound and outbound processing and are working to isolate the issue and fix.
Posted Apr 22, 2025 - 08:08 UTC
Investigating
We are currently investigating this issue.
Posted Apr 22, 2025 - 08:00 UTC
This incident affects: Enterprise Mail Handler for Jira Cloud (JEMHC) (Inbound mail processing, Outbound notification processing).