Delayed Webhook processing and App UI availability (EU)

Incident Report for The Plugin People

Resolved

Changes were applied and no further problems have been observed for several hours.
Posted Sep 17, 2026 - 16:00 UTC

Identified

The issue has been identified and changes are underway.
Posted Sep 17, 2026 - 15:25 UTC

Investigating

We are aware of an issue resulting in delayed Webhook event processing and App UI availability.

Currently, only the EU region is affected.
Posted Sep 17, 2026 - 13:55 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Outbound notification processing, User Interface).