JEMHC User Interface not loading

Incident Report for The Plugin People

Resolved

doesn't appear to be a widespread issue, could be false alarm
Posted Dec 19, 2025 - 22:29 UTC

Monitoring

Seems related to chrome browsers only, alternate browsers are fine.
Posted Dec 19, 2025 - 19:56 UTC

Investigating

We've become aware that the user interface is not loading. This appears to impact other cloud apps as well. No releases or changes were made by us today so we believe this is something in the Atlassian bubble. We've reached out to Atlassian and are awaiting a response. There is nothing we can currently do to address. We do see inbound/outbound mail processing normally.
Posted Dec 19, 2025 - 19:30 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (User Interface).