Mail processing delayed
Incident Report for The Plugin People
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 11, 2018 - 09:14 UTC
Monitoring
Mail processing times appear to be returning to normal ranges.
Posted 5 months ago. Jul 11, 2018 - 08:51 UTC
Identified
We expect the problem to resolve soon.
Posted 5 months ago. Jul 11, 2018 - 08:02 UTC
This incident affected: JEMH Cloud - Inbound and Outbound mail processing.