Delay in app receiving issue events from Atlassian

Incident Report for The Plugin People

Resolved

Atlassian have confirmed the problem is resolved.
Posted May 01, 2026 - 09:57 UTC

Update

Atlassian state that a fix has been deployed. We are continuing to monitor.
Posted Apr 30, 2026 - 13:37 UTC

Update

Atlassian continue to investigate the problem: https://developer.status.atlassian.com/
Posted Apr 30, 2026 - 10:03 UTC

Monitoring

Currently there are no unexpected delays to issue event webhook delivery. We will continue to monitor in case the delay reoccurs.
Posted Apr 29, 2026 - 14:37 UTC

Identified

Issue event webhooks are currently not being sent from Atlassian in a timely manner. Unfortunately this is not something we control. We are reaching out to Atlassian to get this resolved as soon as possible.
Posted Apr 29, 2026 - 13:39 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Outbound notification processing).