JEMHC Attachments not being added through App user
Incident Report for The Plugin People
Resolved
The issue has not occurred over the weekend so considering resolved.
Posted Feb 08, 2021 - 09:03 UTC
Monitoring
Atlassian have rolled out a fix and we are seeing no further errors related to attachments. Continuing to monitor.
Posted Feb 05, 2021 - 20:45 UTC
Identified
The problem appears to be caused by something on Atlassian's side as other app vendors are also reporting the same problem. Awaiting further response from Atlassian on the matter.
Posted Feb 05, 2021 - 13:27 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2021 - 12:02 UTC
Investigating
Inbound Impact:
Attachments are not being added to issues through JEMHC and other 3rd party apps when the App user is the security context.

Outbound Impact:
None found. (referred images or attachments in comments do resolve in outbound messages)

Limited Inbound Workaround:
JEMHC only retains the most recent 100 mails in auditing. Low volume environments could manually review JEMHC > Auditing > Incoming Mail, locate the mail and "View HTML Body", attachments are 'shown', and can be downloaded, for manual addition to issues.

Technical detail:
We have found that JEMHC instances are getting 404 responses from Jira when creating attachments with URL's like:
- /rest/api/latest/issue/ABC-123/attachments (docs : https://developer.atlassian.com/cloud/jira/platform/rest/v3/api-group-issue-attachments)

This happens specifically when the security context the app is working under is the 'App User', rather than when the sender is associated with a Jira user and 'Act As User' feature is enabled.

https://developer.status.atlassian.com/ is now showing the problem, subscribe there for updates.
Posted Feb 05, 2021 - 12:02 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Inbound mail processing, Outbound notification processing).