delayed inbound/outbound mail processing

Incident Report for The Plugin People

Resolved

database issue was root cause, adding scenario to our docs for future quicker resolution.
Posted Dec 30, 2025 - 16:53 UTC

Investigating

We are currently investigating this issue.
Posted Dec 30, 2025 - 15:41 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Inbound mail processing, Outbound notification processing).