Connection authorization issues
Incident Report for The Plugin People
Resolved
A bug in the connection update process caused the underlying OAuth data to be invalidated. In total, roughly 25% of connections were affected. This has now been fixed - any customers still affected by message source or message outbound connections being offline should edit the connection, use the "Authorize" action under the "Name" field and save the form as usual. Apologies once again to those affected for the inconvenience caused.
Posted Apr 12, 2024 - 18:11 UTC
Update
If your connection is offline due to no longer being authorized via OAuth, please edit the connection and use the authorize link HOWEVER once you return to the connection edit screen click cancel on the form at the bottom of the page. We apologize for the inconvenience caused. A fix is being prepared for release.
Posted Apr 12, 2024 - 17:22 UTC
Identified
The issue has been identified. Around 9% of message source connections and around 15% of message outbound connections have gone offline. This is a side-effect of us moving to more efficient authorization token handling. Unfortunately it means that affected customers will need to edit their offline connections that use OAuth and click the "Authorize" button under the name field.
Posted Apr 12, 2024 - 16:51 UTC
Investigating
We are currently investigating elevated levels of failures during authorization of connections to mail sources/outbounds.
Posted Apr 12, 2024 - 15:56 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (Inbound mail processing, Outbound notification processing).