UI
Incident Report for The Plugin People
Resolved
An underlying hardware fault was located and resolved.
Posted Apr 12, 2021 - 13:49 UTC
Investigating
Underlying infrastructure problems impacting JEMHC User Interface which is slow and may time out.
Posted Apr 12, 2021 - 13:14 UTC
This incident affected: Enterprise Mail Handler for Jira Cloud (JEMHC) (User Interface).